aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLukas Larsson <[email protected]>2013-09-02 16:14:11 +0200
committerLukas Larsson <[email protected]>2013-09-02 16:21:24 +0200
commitb5a8aefd0bfa04ea770a9ec869cd079c37278629 (patch)
treea9f147de95550488056810342176c891253e93e6 /configure.in
parente946b152f3b8c5a31b3096a733c6387d9681f0c5 (diff)
parent1477aa1a8b78a806ae6b815e16776a64cf6fbc6e (diff)
downloadotp-b5a8aefd0bfa04ea770a9ec869cd079c37278629.tar.gz
otp-b5a8aefd0bfa04ea770a9ec869cd079c37278629.tar.bz2
otp-b5a8aefd0bfa04ea770a9ec869cd079c37278629.zip
Merge branch 'maint'
* maint: Refactor and change EXTRA_APPLICATIONS to use ls Add configure option --without-$app Conflicts: HOWTO/INSTALL.md lib/Makefile
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 21 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 4b3884864c..bcb0581e0d 100644
--- a/configure.in
+++ b/configure.in
@@ -390,6 +390,15 @@ if test X${enable_native_libs} = Xyes -a X${enable_hipe} != Xno; then
fi
AC_SUBST(NATIVE_LIBS_ENABLED)
+
+rm -f $ERL_TOP/lib/SKIP-APPLICATIONS
+for app in `cd lib && ls -d *`; do
+ var="with_$app"
+ if test X${!var} == Xno; then
+ echo "$app" >> $ERL_TOP/lib/SKIP-APPLICATIONS
+ fi
+done
+
export ERL_TOP
AC_CONFIG_SUBDIRS(lib erts)
@@ -400,15 +409,22 @@ AC_OUTPUT
pattern="lib/*/SKIP"
files=`echo $pattern`
-if test "$files" != "$pattern"; then
+if test "$files" != "$pattern" || test -f $ERL_TOP/lib/SKIP-APPLICATIONS; then
echo '*********************************************************************'
echo '********************** APPLICATIONS DISABLED **********************'
echo '*********************************************************************'
echo
- for skipfile in $files; do
- app=`dirname $skipfile`; app=`basename $app`
- printf "%-15s: " $app; cat $skipfile
- done
+ if test "$files" != "$pattern"; then
+ for skipfile in $files; do
+ app=`dirname $skipfile`; app=`basename $app`
+ printf "%-15s: " $app; cat $skipfile
+ done
+ fi
+ if test -f $ERL_TOP/lib/SKIP-APPLICATIONS; then
+ for skipapp in `cat $ERL_TOP/lib/SKIP-APPLICATIONS`; do
+ printf "%-15s: User gave --without-%s option\n" $skipapp $skipapp
+ done
+ fi
echo
echo '*********************************************************************'
fi