From 59740d8fee66f3326b30ac25882b52ffada4bac2 Mon Sep 17 00:00:00 2001
From: Peter Lemenkov <lemenkov@gmail.com>
Date: Fri, 6 Jun 2014 15:29:49 +0400
Subject: epmd: Added systemd notify support to EPMD

Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
---
 erts/configure.in | 3 +++
 1 file changed, 3 insertions(+)

(limited to 'erts/configure.in')

diff --git a/erts/configure.in b/erts/configure.in
index 9864d03cde..a594d59355 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1691,10 +1691,13 @@ systemd_daemon_save_LIBS=$LIBS
 LIBS=
 AC_SEARCH_LIBS(sd_listen_fds,[systemd systemd-daemon],
   [have_sd_listen_fds=yes],[have_sd_listen_fds=no],$systemd_daemon_save_LIBS)
+AC_SEARCH_LIBS(sd_notify,[systemd systemd-daemon],
+  [have_sd_notify=yes],[have_sd_notify=no],$systemd_daemon_save_LIBS)
 AC_CHECK_HEADERS(systemd/sd-daemon.h,
   [have_systemd_sd_daemon_h=yes],[have_systemd_sd_daemon_h=no])
 
 if test x"$have_sd_listen_fds" = x"yes" && \
+   test x"$have_sd_notify" = x"yes" && \
    test x"$have_systemd_sd_daemon_h" = x"yes"; then
   AC_DEFINE([HAVE_SYSTEMD_DAEMON],[1],[Define if you have systemd daemon])
   SYSTEMD_DAEMON_LIBS=$LIBS
-- 
cgit v1.2.3