aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBjörn-Egil Dahlberg <[email protected]>2013-01-18 14:36:23 +0100
committerBjörn-Egil Dahlberg <[email protected]>2013-01-18 14:36:23 +0100
commitb0e4f20f2abde9fc264995317966f373775e2b2b (patch)
treec2ded39c850156a1aafbc69fa1bc48ba08101922 /configure.in
parent40e7a6da2054b9c430360bd5dd656b1d43f6c6ef (diff)
parentfed9a8415fc77ed42bf9a94ea421eff4f62c5eb4 (diff)
downloadotp-b0e4f20f2abde9fc264995317966f373775e2b2b.tar.gz
otp-b0e4f20f2abde9fc264995317966f373775e2b2b.tar.bz2
otp-b0e4f20f2abde9fc264995317966f373775e2b2b.zip
Merge branch 'nox/enable-silent-rules/OTP-10726'
* nox/enable-silent-rules/OTP-10726: Implement ./otp_build configure --enable-silent-rules
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e906c17ecc..c0994245e8 100644
--- a/configure.in
+++ b/configure.in
@@ -354,6 +354,21 @@ elif test X"$TMPSYS" '=' X"Darwin-i386"; then
export LDFLAGS
fi
+AC_ARG_ENABLE([silent-rules], [dnl
+AS_HELP_STRING(
+ [--enable-silent-rules],
+ [less verbose build output (undo: "make V=1")])
+AS_HELP_STRING(
+ [--disable-silent-rules],
+ [verbose build output (undo: "make V=0")])dnl
+])
+
+DEFAULT_VERBOSITY=1
+if test X${enable_silent_rules} = Xyes; then
+ DEFAULT_VERBOSITY=0
+fi
+AC_SUBST(DEFAULT_VERBOSITY)
+
if test X${enable_m64_build} = Xyes; then
enable_hipe=no
CFLAGS="-m64 $CFLAGS"
@@ -378,7 +393,7 @@ AC_SUBST(NATIVE_LIBS_ENABLED)
export ERL_TOP
AC_CONFIG_SUBDIRS(lib erts)
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile make/output.mk])
AC_CONFIG_FILES([make/emd2exml], [chmod +x make/emd2exml])
AC_OUTPUT