aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDániel Szoboszlay <[email protected]>2014-04-28 17:20:24 +0200
committerMagnus Henoch <[email protected]>2016-09-28 15:08:31 +0100
commit0a1feff48388c8430f5eebd1531f769605601fab (patch)
treee21885594ce82dac0a7327a6222b959efbc4f4be /configure.in
parent867ef8aab0a32d76e6e66b317ef39c75e84e177e (diff)
downloadotp-0a1feff48388c8430f5eebd1531f769605601fab.tar.gz
otp-0a1feff48388c8430f5eebd1531f769605601fab.tar.bz2
otp-0a1feff48388c8430f5eebd1531f769605601fab.zip
Support using OpenSSL in FIPS mode
FIPS mode support needs to be enabled at compile time, by configuring Erlang/OTP with --enable-fips option. In FIPS mode the non-FIPS algorithms are disabled and raise error notsup. The supported protocols list is properly updated in FIPS mode to advertise only the enabled protocols. FIPS mode is off by default even if Erlang/OTP was built with FIPS support. It needs to be turned on at runtime. The official approach is to set the fips_mode application environment parameter of the crypto application to true. This would turn FIPS mode on when the NIF is loaded and would prevent loading the module on error. Another method is provided via the crypto:enable_fips_mode/1 function, but it is not recommended to be used in production, as it won't prevent the use of the crypto module in case of an error, and would risk OpenSSL crashing the emulator. It is very useful for test suites however that need to check both validated and non-validated functionality. This commit is based on commit 00b3a04d17a653b4abddeebd6dd8a2c38df532d0.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ea98dc9836..3a1f8d5505 100644
--- a/configure.in
+++ b/configure.in
@@ -281,6 +281,10 @@ AC_ARG_ENABLE(dynamic-ssl-lib,
AS_HELP_STRING([--disable-dynamic-ssl-lib],
[disable using dynamic openssl libraries]))
+AC_ARG_ENABLE(fips,
+AS_HELP_STRING([--enable-fips], [enable OpenSSL FIPS mode support])
+AS_HELP_STRING([--disable-fips], [disable OpenSSL FIPS mode support (default)]))
+
AC_ARG_ENABLE(builtin-zlib,
AS_HELP_STRING([--enable-builtin-zlib],
[force use of our own built-in zlib]))