aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLukas Larsson <[email protected]>2013-08-29 18:04:49 +0200
committerLukas Larsson <[email protected]>2013-09-02 16:11:07 +0200
commit0ed2039a7bef0137c1c6723e0401f96b7bf71de3 (patch)
tree782c4835f4a4bccd356ecc0048d7afa4eb8d3449 /configure.in
parent6fc94ba0b93488e46429dd4e71d11ebfe3b62792 (diff)
downloadotp-0ed2039a7bef0137c1c6723e0401f96b7bf71de3.tar.gz
otp-0ed2039a7bef0137c1c6723e0401f96b7bf71de3.tar.bz2
otp-0ed2039a7bef0137c1c6723e0401f96b7bf71de3.zip
Add configure option --without-$app
This is used to skip the specified app when building and releasing
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 21 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 4b3884864c..bcb0581e0d 100644
--- a/configure.in
+++ b/configure.in
@@ -390,6 +390,15 @@ if test X${enable_native_libs} = Xyes -a X${enable_hipe} != Xno; then
fi
AC_SUBST(NATIVE_LIBS_ENABLED)
+
+rm -f $ERL_TOP/lib/SKIP-APPLICATIONS
+for app in `cd lib && ls -d *`; do
+ var="with_$app"
+ if test X${!var} == Xno; then
+ echo "$app" >> $ERL_TOP/lib/SKIP-APPLICATIONS
+ fi
+done
+
export ERL_TOP
AC_CONFIG_SUBDIRS(lib erts)
@@ -400,15 +409,22 @@ AC_OUTPUT
pattern="lib/*/SKIP"
files=`echo $pattern`
-if test "$files" != "$pattern"; then
+if test "$files" != "$pattern" || test -f $ERL_TOP/lib/SKIP-APPLICATIONS; then
echo '*********************************************************************'
echo '********************** APPLICATIONS DISABLED **********************'
echo '*********************************************************************'
echo
- for skipfile in $files; do
- app=`dirname $skipfile`; app=`basename $app`
- printf "%-15s: " $app; cat $skipfile
- done
+ if test "$files" != "$pattern"; then
+ for skipfile in $files; do
+ app=`dirname $skipfile`; app=`basename $app`
+ printf "%-15s: " $app; cat $skipfile
+ done
+ fi
+ if test -f $ERL_TOP/lib/SKIP-APPLICATIONS; then
+ for skipapp in `cat $ERL_TOP/lib/SKIP-APPLICATIONS`; do
+ printf "%-15s: User gave --without-%s option\n" $skipapp $skipapp
+ done
+ fi
echo
echo '*********************************************************************'
fi