aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlexey Lebedeff <[email protected]>2016-06-15 10:40:36 +0300
committerAlexey Lebedeff <[email protected]>2016-06-15 10:40:36 +0300
commit9f9841eb7327c9fe73e84e197fd2965a97b639cf (patch)
treeb124a5d370468e47a289db92a2d52933e60a9d00 /configure.in
parent481ac2a246c53c29033648ae5adda2c215fcc924 (diff)
downloadotp-9f9841eb7327c9fe73e84e197fd2965a97b639cf.tar.gz
otp-9f9841eb7327c9fe73e84e197fd2965a97b639cf.tar.bz2
otp-9f9841eb7327c9fe73e84e197fd2965a97b639cf.zip
Don't make assumptions about build tools paths
One more followup to https://github.com/erlang/otp/pull/1056 and https://github.com/erlang/otp/pull/1023 This time it's about `/usr/bin/env` and `/bin/cp`: - `/usr/bin/env` in `diameterc` was used to find the bootstrapped `escript` executable. Changed it to exlpicit call to `escript` in Makefile. - `/usr/bin/env` and `/bin/cp` were referenced in documentation build/install process. Now full paths to this tools are injected using autoconf magic.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8a7f372a50..ea98dc9836 100644
--- a/configure.in
+++ b/configure.in
@@ -129,6 +129,13 @@ AC_PROG_CC
AC_PROG_CXX
AC_CHECK_TOOL(LD, [ld])
+_search_path=/bin:/usr/bin:/usr/local/bin:$PATH
+
+AC_PATH_PROG(ENV, [env], false, $_search_path)
+if test "$ac_cv_path_ENV" = false; then
+ AC_MSG_ERROR([No 'env' command found])
+fi
+
#
# We need GNU make, complain if we can't find it
#