aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPatrik Nyblom <[email protected]>2009-12-08 09:02:14 +0100
committerBjörn Gustavsson <[email protected]>2010-02-06 09:49:00 +0100
commitcad901a54fa7d0eb3ad17270a08d4824d50cfd51 (patch)
tree8e7f24c6baedf3bf31b73e72c77605fcc693cb35 /configure.in
parentc6bf34b7035a6292650babf2eb8af80c19256fab (diff)
downloadotp-cad901a54fa7d0eb3ad17270a08d4824d50cfd51.tar.gz
otp-cad901a54fa7d0eb3ad17270a08d4824d50cfd51.tar.bz2
otp-cad901a54fa7d0eb3ad17270a08d4824d50cfd51.zip
Teach configure --enable-m32-build for forcing a 32-bit build
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 19ef304a1a..2a9a2c50b2 100644
--- a/configure.in
+++ b/configure.in
@@ -272,6 +272,19 @@ AC_ARG_ENABLE(m64-build,
esac
],enable_m64_build=no)
+AC_ARG_ENABLE(m32-build,
+[ --enable-m32-build build 32bit binaries using the -m32 flag to (g)cc],
+[ case "$enableval" in
+ no) enable_m32_build=no ;;
+ *)
+ if test X${enable_darwin_64bit} = Xyes -o X${enable_m64_build} = Xyes;
+ then
+ AC_MSG_ERROR([(--enable-darwin-64bit or --enable-m64-build) and --enable-m32-build are mutually exclusive]) ;
+ fi ;
+ enable_m32_build=yes ;;
+ esac
+],enable_m32_build=no)
+
dnl OK, we might have darwin switches off different kinds, lets
dnl check it all before continuing.
TMPSYS=`uname -s`-`uname -m`
@@ -315,6 +328,13 @@ if test X${enable_m64_build} = Xyes; then
LDFLAGS="-m64 $LDFLAGS"
export LDFLAGS
fi
+if test X${enable_m32_build} = Xyes; then
+ enable_hipe=no
+ CFLAGS="-m32 $CFLAGS"
+ export CFLAGS
+ LDFLAGS="-m32 $LDFLAGS"
+ export LDFLAGS
+fi
export ERL_TOP
AC_CONFIG_SUBDIRS(lib erts)