aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2010-03-22 10:24:35 +0000
committerErlang/OTP <[email protected]>2010-03-22 10:24:35 +0000
commitd041cab91829ebacbd35ce2c5927f6ebe69b417a (patch)
treea3b40b6db27323c8ee10f8b873e4e03cbe7906cf /configure.in
parent14801bff88836ad47850c91287b3126f132b5d65 (diff)
downloadotp-d041cab91829ebacbd35ce2c5927f6ebe69b417a.tar.gz
otp-d041cab91829ebacbd35ce2c5927f6ebe69b417a.tar.bz2
otp-d041cab91829ebacbd35ce2c5927f6ebe69b417a.zip
OTP-8512 Add Erlangish MarkDown to Erlangish XML support
The INSTALL.md, INSTALL-CROSS.md, and INSTALL-WIN32.md "readme files" are now included in both the HTML and the PDF documentation.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 10 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 21f9a640ff..4591df1099 100644
--- a/configure.in
+++ b/configure.in
@@ -182,14 +182,14 @@ AC_PROG_RANLIB
# Get erts version and otp release from erts/vsn.mk
#
AC_MSG_CHECKING([ERTS version])
-[ERTS=erts-`sed -n "s/^VSN[ ]*=[ ]*\(.*\)/\1/p" < $ERL_TOP/erts/vsn.mk`]
-AC_MSG_RESULT([$ERTS])
-AC_SUBST(ERTS)
+[ERTS_VSN=`sed -n "s/^VSN[ ]*=[ ]*\(.*\)/\1/p" < $ERL_TOP/erts/vsn.mk`]
+AC_MSG_RESULT([$ERTS_VSN])
+AC_SUBST(ERTS_VSN)
AC_MSG_CHECKING([OTP release])
-[OTP=OTP-`sed -n "s/^SYSTEM_VSN[ ]*=[ ]*\(.*\)/\1/p" < $ERL_TOP/erts/vsn.mk`]
-AC_MSG_RESULT([$OTP])
-AC_SUBST(OTP)
+[OTP_REL=`sed -n "s/^SYSTEM_VSN[ ]*=[ ]*\(.*\)/\1/p" < $ERL_TOP/erts/vsn.mk`]
+AC_MSG_RESULT([$OTP_REL])
+AC_SUBST(OTP_REL)
AC_ARG_ENABLE(threads,
[ --enable-threads enable async thread support
@@ -343,7 +343,10 @@ fi
export ERL_TOP
AC_CONFIG_SUBDIRS(lib erts)
-AC_OUTPUT(Makefile)
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([make/emd2exml], [chmod +x make/emd2exml])
+
+AC_OUTPUT
pattern="lib/*/SKIP"
files=`echo $pattern`