aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSverker Eriksson <[email protected]>2014-09-10 20:48:24 +0200
committerSverker Eriksson <[email protected]>2014-09-10 20:48:24 +0200
commitdf5ecc7200c275eb4ac43b79fa2e587d571da696 (patch)
treeafc3151389e0f37ee101458423d18e9a9e03a266 /configure.in
parentebd23a3de8418fd70a8d12dfc90bce0fa283f4e5 (diff)
downloadotp-df5ecc7200c275eb4ac43b79fa2e587d571da696.tar.gz
otp-df5ecc7200c275eb4ac43b79fa2e587d571da696.tar.bz2
otp-df5ecc7200c275eb4ac43b79fa2e587d571da696.zip
Add configure option --with-ssl-incl=PATH
to be used together with --with-ssl=PATH if the include directory is in another location.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 780e660f9d..be169b8428 100644
--- a/configure.in
+++ b/configure.in
@@ -262,6 +262,10 @@ AS_HELP_STRING([--with-ssl=PATH], [specify location of OpenSSL include and lib])
AS_HELP_STRING([--with-ssl], [use SSL (default)])
AS_HELP_STRING([--without-ssl], [don't use SSL]))
+AC_ARG_WITH(ssl-incl,
+AS_HELP_STRING([--with-ssl-incl=PATH],
+ [location of OpenSSL include dir, if different than specified by --with-ssl=PATH]))
+
AC_ARG_ENABLE(dynamic-ssl-lib,
AS_HELP_STRING([--disable-dynamic-ssl-lib],
[disable using dynamic openssl libraries]))