aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLukas Larsson <[email protected]>2013-09-02 16:11:44 +0200
committerLukas Larsson <[email protected]>2013-09-02 16:11:44 +0200
commit1477aa1a8b78a806ae6b815e16776a64cf6fbc6e (patch)
tree51557c68259af7aa920a3885e84cfea1527dd2f5 /configure.in
parent1a57f9d04b0e846ba6dccdb99643c4f7ab17705f (diff)
parentdbc8066d21384db9829e8b58cd99a4fc223e83ac (diff)
downloadotp-1477aa1a8b78a806ae6b815e16776a64cf6fbc6e.tar.gz
otp-1477aa1a8b78a806ae6b815e16776a64cf6fbc6e.tar.bz2
otp-1477aa1a8b78a806ae6b815e16776a64cf6fbc6e.zip
Merge branch 'lukas/skip-extra-applications/OTP-11288' into maint
* lukas/skip-extra-applications/OTP-11288: Refactor and change EXTRA_APPLICATIONS to use ls Add configure option --without-$app
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 21 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 4b3884864c..bcb0581e0d 100644
--- a/configure.in
+++ b/configure.in
@@ -390,6 +390,15 @@ if test X${enable_native_libs} = Xyes -a X${enable_hipe} != Xno; then
fi
AC_SUBST(NATIVE_LIBS_ENABLED)
+
+rm -f $ERL_TOP/lib/SKIP-APPLICATIONS
+for app in `cd lib && ls -d *`; do
+ var="with_$app"
+ if test X${!var} == Xno; then
+ echo "$app" >> $ERL_TOP/lib/SKIP-APPLICATIONS
+ fi
+done
+
export ERL_TOP
AC_CONFIG_SUBDIRS(lib erts)
@@ -400,15 +409,22 @@ AC_OUTPUT
pattern="lib/*/SKIP"
files=`echo $pattern`
-if test "$files" != "$pattern"; then
+if test "$files" != "$pattern" || test -f $ERL_TOP/lib/SKIP-APPLICATIONS; then
echo '*********************************************************************'
echo '********************** APPLICATIONS DISABLED **********************'
echo '*********************************************************************'
echo
- for skipfile in $files; do
- app=`dirname $skipfile`; app=`basename $app`
- printf "%-15s: " $app; cat $skipfile
- done
+ if test "$files" != "$pattern"; then
+ for skipfile in $files; do
+ app=`dirname $skipfile`; app=`basename $app`
+ printf "%-15s: " $app; cat $skipfile
+ done
+ fi
+ if test -f $ERL_TOP/lib/SKIP-APPLICATIONS; then
+ for skipapp in `cat $ERL_TOP/lib/SKIP-APPLICATIONS`; do
+ printf "%-15s: User gave --without-%s option\n" $skipapp $skipapp
+ done
+ fi
echo
echo '*********************************************************************'
fi