aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2013-07-08 17:20:21 +0200
committerRickard Green <[email protected]>2013-07-09 14:40:14 +0200
commit876d39cd86446ba0fe79ad20f1d261e5d85d659b (patch)
treefc697d4776df8d6bf25c3f086c07ca8fbfbed977 /configure.in
parentb3b0c44ca3f1b87c719f782f09dd0331dbb1a351 (diff)
downloadotp-876d39cd86446ba0fe79ad20f1d261e5d85d659b.tar.gz
otp-876d39cd86446ba0fe79ad20f1d261e5d85d659b.tar.bz2
otp-876d39cd86446ba0fe79ad20f1d261e5d85d659b.zip
Refuse to build SMP runtime by default without native atomics
Build with fallback can be enabled by passing the `configure` command line argument `--disable-smp-require-native-atomics`
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c0994245e8..4b3884864c 100644
--- a/configure.in
+++ b/configure.in
@@ -419,6 +419,7 @@ if test "$files" != "$pattern" || test -f erts/CONF_INFO; then
echo '********************** APPLICATIONS INFORMATION *******************'
echo '*********************************************************************'
echo
+ test "$files" != "$pattern" || files=""
test ! -f erts/CONF_INFO || files="$files erts/CONF_INFO"
for infofile in $files; do
app=`dirname $infofile`; app=`basename $app`