aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAnthony Ramine <[email protected]>2012-11-28 11:45:47 +0100
committerAnthony Ramine <[email protected]>2013-01-15 21:42:34 +0100
commitfed9a8415fc77ed42bf9a94ea421eff4f62c5eb4 (patch)
treed0bf98bd4b28d868656224193f838886e0419990 /configure.in
parent3e8a6c8bceea8552ef50bd8dcfc14a0f79c9f32e (diff)
downloadotp-fed9a8415fc77ed42bf9a94ea421eff4f62c5eb4.tar.gz
otp-fed9a8415fc77ed42bf9a94ea421eff4f62c5eb4.tar.bz2
otp-fed9a8415fc77ed42bf9a94ea421eff4f62c5eb4.zip
Implement ./otp_build configure --enable-silent-rules
With silent rules, the output of make is less verbose and compilation warnings are easier to spot. Silent rules are disabled by default and can be disabled or enabled at will by make V=0 and make V=1.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e906c17ecc..c0994245e8 100644
--- a/configure.in
+++ b/configure.in
@@ -354,6 +354,21 @@ elif test X"$TMPSYS" '=' X"Darwin-i386"; then
export LDFLAGS
fi
+AC_ARG_ENABLE([silent-rules], [dnl
+AS_HELP_STRING(
+ [--enable-silent-rules],
+ [less verbose build output (undo: "make V=1")])
+AS_HELP_STRING(
+ [--disable-silent-rules],
+ [verbose build output (undo: "make V=0")])dnl
+])
+
+DEFAULT_VERBOSITY=1
+if test X${enable_silent_rules} = Xyes; then
+ DEFAULT_VERBOSITY=0
+fi
+AC_SUBST(DEFAULT_VERBOSITY)
+
if test X${enable_m64_build} = Xyes; then
enable_hipe=no
CFLAGS="-m64 $CFLAGS"
@@ -378,7 +393,7 @@ AC_SUBST(NATIVE_LIBS_ENABLED)
export ERL_TOP
AC_CONFIG_SUBDIRS(lib erts)
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile make/output.mk])
AC_CONFIG_FILES([make/emd2exml], [chmod +x make/emd2exml])
AC_OUTPUT