aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorBjörn Gustavsson <[email protected]>2016-11-29 07:45:15 +0100
committerBjörn Gustavsson <[email protected]>2016-12-02 13:19:58 +0100
commit25aa0128340d819e85e641f0ef8b9e0fd5fdda0b (patch)
treeb741449f74cfcb0f6da4a5f84ed494ffc773e938 /erts/configure.in
parent4355489a25795382360fb5ac4ac58f060c331462 (diff)
downloadotp-25aa0128340d819e85e641f0ef8b9e0fd5fdda0b.tar.gz
otp-25aa0128340d819e85e641f0ef8b9e0fd5fdda0b.tar.bz2
otp-25aa0128340d819e85e641f0ef8b9e0fd5fdda0b.zip
configure.in: Fix test for SSL with Kerberos
OpenSSL 1.1.0 and higher does not support Kerberos and no longer defines OPENSSL_NO_KRB5 to indicate that. Test the version number as well as OPENSSL_NO_KRB5.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 98f3e6bcc5..fd7dc783f3 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -4447,12 +4447,14 @@ esac
if test "x$SSL_APP" != "x" ; then
dnl We found openssl, now check if we use kerberos 5 support
+ dnl FIXME: Do we still support platforms that have Kerberos?
AC_MSG_CHECKING(for OpenSSL kerberos 5 support)
old_CPPFLAGS=$CPPFLAGS
CPPFLAGS=$SSL_INCLUDE
AC_EGREP_CPP(^yes$,[
+#include <openssl/opensslv.h>
#include <openssl/opensslconf.h>
-#ifndef OPENSSL_NO_KRB5
+#if OPENSSL_VERSION_NUMBER < 0x1010000fL && !defined(OPENSSL_NO_KRB5)
yes
#endif
],[