aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorLukas Larsson <[email protected]>2018-12-03 14:42:15 +0100
committerLukas Larsson <[email protected]>2018-12-03 14:42:15 +0100
commit7515f713da271618c688de768f1586280fcc9635 (patch)
tree0b139876b58ecc12ba21727138db9459fc19227d /erts/configure.in
parent28d77314ceb96cda8f270eccaa60af625bbe0e76 (diff)
parent0d24aecf46f9f387d64f06744f8a55b841669d1e (diff)
downloadotp-7515f713da271618c688de768f1586280fcc9635.tar.gz
otp-7515f713da271618c688de768f1586280fcc9635.tar.bz2
otp-7515f713da271618c688de768f1586280fcc9635.zip
Merge branch 'maint'
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 0323058b4a..05379f74ee 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -570,6 +570,17 @@ else
WFLAGS=""
WERRORFLAGS=""
fi
+
+AC_MSG_CHECKING([CFLAGS for -O switch])
+case "$CFLAGS" in
+ *-O*) AC_MSG_RESULT([yes]) ;;
+ *)
+ AC_MSG_ERROR([
+ CFLAGS must contain a -O flag. If you need to edit the CFLAGS you probably
+ also want to add the default CFLAGS. The default CFLAGS are "-O2 -g".
+ If you want to build erts without any optimization, pass -O0 to CFLAGS.]) ;;
+esac
+
dnl DEBUG_FLAGS is obsolete (I hope)
AC_SUBST(DEBUG_FLAGS)
AC_SUBST(DEBUG_CFLAGS)