aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorSverker Eriksson <[email protected]>2016-11-09 17:25:25 +0100
committerSverker Eriksson <[email protected]>2016-11-14 14:40:44 +0100
commite770c849d011d8d5872e5f1400d77c25a9268186 (patch)
treefea6ae49ae0041ed2bcdcc878eb68f1e79a4fbef /erts/configure.in
parentb41e8edf3b7076470c45233d30686dd8b0abc871 (diff)
downloadotp-e770c849d011d8d5872e5f1400d77c25a9268186.tar.gz
otp-e770c849d011d8d5872e5f1400d77c25a9268186.tar.bz2
otp-e770c849d011d8d5872e5f1400d77c25a9268186.zip
erts: Add gcc compile error -Werror=undef
to get errors for "#if UNDEFINED_MACRO"
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 4bff2ebf3d..fe340b34eb 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -533,6 +533,7 @@ if test "x$GCC" = xyes; then
# Treat certain GCC warnings as errors
LM_TRY_ENABLE_CFLAG([-Werror=return-type], [WERRORFLAGS])
LM_TRY_ENABLE_CFLAG([-Werror=implicit], [WERRORFLAGS])
+ LM_TRY_ENABLE_CFLAG([-Werror=undef], [WERRORFLAGS])
# until the emulator can handle this, I suggest we turn it off!
#WFLAGS="-Wall -Wshadow -Wcast-qual -Wmissing-declarations"