aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorAlexey Lebedeff <[email protected]>2016-06-15 10:40:36 +0300
committerAlexey Lebedeff <[email protected]>2016-06-15 10:40:36 +0300
commit9f9841eb7327c9fe73e84e197fd2965a97b639cf (patch)
treeb124a5d370468e47a289db92a2d52933e60a9d00 /erts/configure.in
parent481ac2a246c53c29033648ae5adda2c215fcc924 (diff)
downloadotp-9f9841eb7327c9fe73e84e197fd2965a97b639cf.tar.gz
otp-9f9841eb7327c9fe73e84e197fd2965a97b639cf.tar.bz2
otp-9f9841eb7327c9fe73e84e197fd2965a97b639cf.zip
Don't make assumptions about build tools paths
One more followup to https://github.com/erlang/otp/pull/1056 and https://github.com/erlang/otp/pull/1023 This time it's about `/usr/bin/env` and `/bin/cp`: - `/usr/bin/env` in `diameterc` was used to find the bootstrapped `escript` executable. Changed it to exlpicit call to `escript` in Makefile. - `/usr/bin/env` and `/bin/cp` were referenced in documentation build/install process. Now full paths to this tools are injected using autoconf magic.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 81ecad4f51..7986a55911 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -738,6 +738,11 @@ if test "$ac_cv_path_MKDIR" = false; then
AC_MSG_ERROR([No 'mkdir' command found])
fi
+AC_PATH_PROG(CP, cp, false, $_search_path)
+if test "$ac_cv_path_CP" = false; then
+ AC_MSG_ERROR([No 'cp' command found])
+fi
+
_search_path=