aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorYiannis Tsiouris <[email protected]>2013-01-22 18:16:33 +0200
committerBjörn-Egil Dahlberg <[email protected]>2015-11-17 14:45:45 +0100
commiteebdde01b149ea45966c7412bc2a062136457b54 (patch)
treea2d73dbb183d1ffc4a02992fb38b527538568f76 /erts/configure.in
parent277e8e77384ed6628009243e63d62f0555d10c69 (diff)
downloadotp-eebdde01b149ea45966c7412bc2a062136457b54.tar.gz
otp-eebdde01b149ea45966c7412bc2a062136457b54.tar.bz2
otp-eebdde01b149ea45966c7412bc2a062136457b54.zip
Add --enable-sharing-preserving configure flag
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 2419925c33..9ad1588b6c 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -788,6 +788,18 @@ esac
AC_SUBST(LIBCARBON)
+dnl Check if we should/can build a sharing-preserving emulator
+
+AC_MSG_CHECKING(if we are building a sharing-preserving emulator)
+if test "$enable_sharing_preserving" = "yes"; then
+ AC_DEFINE(SHCOPY, [1],
+ [Define if building a sharing-preserving emulator])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+
dnl some tests below will call this if we haven't already - and autoconf
dnl can't handle those tests being done conditionally at runtime
AC_PROG_CPP