aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorLukas Larsson <[email protected]>2011-12-02 17:13:49 +0100
committerLukas Larsson <[email protected]>2011-12-05 19:39:40 +0100
commit250a556b1e3eb8486ec294f94d3b918c9ac91542 (patch)
treec3d8795be62b7b349aae6aec92f6f8d1583415db /erts/configure.in
parent62fffa75e2003b3f19eb7614307942028a400fd1 (diff)
downloadotp-250a556b1e3eb8486ec294f94d3b918c9ac91542.tar.gz
otp-250a556b1e3eb8486ec294f94d3b918c9ac91542.tar.bz2
otp-250a556b1e3eb8486ec294f94d3b918c9ac91542.zip
Make solaris use sendfilev
sendfilev is a richer API which allows us to do non blocking TCP on solaris. The normal sendfile API seems to have some issue with non blocking sockets and the return value of sendfile.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 548e4cc9d5..e937184f62 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1697,7 +1697,9 @@ case $host_os in
AC_CHECK_FUNCS([sendfile])
;;
solaris*)
- AC_SEARCH_LIBS(sendfile, sendfile, AC_DEFINE(HAVE_SENDFILE, 1))
+ AC_SEARCH_LIBS(sendfilev, sendfile,
+ AC_DEFINE([HAVE_SENDFILEV],[1],
+ [Define to 1 if you have the `sendfilev' function.]))
;;
win32)
LIBS="$LIBS -lmswsock"