aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorJohan Oudinet <[email protected]>2015-03-24 15:54:31 +0100
committerZandra Hird <[email protected]>2015-04-29 15:12:40 +0200
commit871770f169f6a9a996d22cbd63128c53b7b4370c (patch)
treea6c203b7f85d20b5dff21e44ec0113b912d2ea93 /erts/configure.in
parent147e8b9bd0b36315f0d8bd38e39c51d93cd9f509 (diff)
downloadotp-871770f169f6a9a996d22cbd63128c53b7b4370c.tar.gz
otp-871770f169f6a9a996d22cbd63128c53b7b4370c.tar.bz2
otp-871770f169f6a9a996d22cbd63128c53b7b4370c.zip
erts: Fix incorrect use of AC_EGREP_CPP
Using 'AC_EGREP_CPP(yes' without restraining the pattern always return true if it runs from a path containing the string 'yes'.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in17
1 files changed, 9 insertions, 8 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 873e1e30fe..2d234e5f66 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1558,10 +1558,11 @@ if test "$have_gethostbyname_r" = yes; then
[Define to flavour of gethostbyname_r]))
;;
*)
- AC_EGREP_CPP(yes,[#include <stdio.h>
- #ifdef __GLIBC__
- yes
- #endif
+ AC_EGREP_CPP(^yes$,[
+#include <stdio.h>
+#ifdef __GLIBC__
+yes
+#endif
], AC_DEFINE(HAVE_GETHOSTBYNAME_R, GHBN_R_GLIBC,
[Define to flavour of gethostbyname_r]))
;;
@@ -4293,10 +4294,10 @@ case "$erl_xcomp_without_sysroot-$with_ssl" in
SSL_INCLUDE="-I$dir/include"
old_CPPFLAGS=$CPPFLAGS
CPPFLAGS=$SSL_INCLUDE
- AC_EGREP_CPP(yes,[
+ AC_EGREP_CPP(^yes$,[
#include <openssl/opensslv.h>
#if OPENSSL_VERSION_NUMBER >= 0x0090700fL
- yes
+yes
#endif
],[
ssl_found=yes
@@ -4491,10 +4492,10 @@ if test "x$SSL_APP" != "x" ; then
AC_MSG_CHECKING(for OpenSSL kerberos 5 support)
old_CPPFLAGS=$CPPFLAGS
CPPFLAGS=$SSL_INCLUDE
- AC_EGREP_CPP(yes,[
+ AC_EGREP_CPP(^yes$,[
#include <openssl/opensslconf.h>
#ifndef OPENSSL_NO_KRB5
- yes
+yes
#endif
],[
AC_MSG_RESULT([yes])