aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorBjörn Gustavsson <[email protected]>2011-11-29 15:46:20 +0100
committerBjörn Gustavsson <[email protected]>2011-11-30 06:56:01 +0100
commitfa0f8d2c29b9ec44f0fa85cacc375979b175348b (patch)
tree6a752ff7bf69c32e7d41098793b29f15f80652f2 /erts/configure.in
parentdb0289277e9e2bc2e06a8530d39af65a94fd8ba3 (diff)
downloadotp-fa0f8d2c29b9ec44f0fa85cacc375979b175348b.tar.gz
otp-fa0f8d2c29b9ec44f0fa85cacc375979b175348b.tar.bz2
otp-fa0f8d2c29b9ec44f0fa85cacc375979b175348b.zip
Disable floating point exceptions on Mac OS X by default
Many test cases provoke printouts similar to: ERTS_FP_CHECK_INIT at 0x131fd218: detected unhandled FPE at 0x1 Until the problem has been identified and fixed, disable floating point exceptions by default on Mac OS X.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index e3eb6034e6..03125acced 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -2458,6 +2458,17 @@ case $ARCH-$OPSYS in
darwin_mcontext_leopard=no
;;
esac
+
+if test X${enable_fp_exceptions} = Xauto ; then
+ case $host_os in
+ darwin*)
+ enable_fp_exceptions=no
+ AC_MSG_NOTICE([Floating point exceptions disabled by default on MacOS X]) ;;
+ *)
+ ;;
+ esac
+fi
+
if test X${enable_fp_exceptions} = Xauto ; then
if test X${enable_hipe} = Xyes; then
enable_fp_exceptions=yes