aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorRaimo Niskanen <[email protected]>2012-10-31 09:17:15 +0100
committerRaimo Niskanen <[email protected]>2012-10-31 09:17:15 +0100
commit0a42a8be1604a29bfefd62e54a2e8453e237fd73 (patch)
treeba3754c1ab72ba52f31a7d8f06781cfa9d5eea87 /erts/configure.in
parent465be6cd854681093971c2bb0d678993168f4a3e (diff)
parent7028c8e756129cbb7898798fc81a16de3625709f (diff)
downloadotp-0a42a8be1604a29bfefd62e54a2e8453e237fd73.tar.gz
otp-0a42a8be1604a29bfefd62e54a2e8453e237fd73.tar.bz2
otp-0a42a8be1604a29bfefd62e54a2e8453e237fd73.zip
Merge branch 'raimo/IPV6_V6ONLY/OTP-8928'
* raimo/IPV6_V6ONLY/OTP-8928: kernel: Document socket option ipv6_v6only kernel: Add test cases for socket option ipv6_v6only erts,kernel: Implement socket option ipv6_v6only in erlang code erts: Implement socket option IPV6_V6ONLY erts: Add configure test for IPV6_V6ONLY
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 6ad1951a4e..3256b0cb59 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -2000,8 +2000,12 @@ case "$erts_cv_have_in6addr_loopback" in
[Define to 1 if you have the variable in6addr_loopback declared.])
esac
-AC_CHECK_DECLS([IN6ADDR_ANY_INIT, IN6ADDR_LOOPBACK_INIT], [], [],
- [#include <netinet/in.h>])
+AC_CHECK_DECLS([IN6ADDR_ANY_INIT, IN6ADDR_LOOPBACK_INIT, IPV6_V6ONLY], [], [],
+ [
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ ])
dnl ----------------------------------------------------------------------
dnl Checks for features/quirks in the system that affects Erlang.