aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorBjörn Gustavsson <[email protected]>2012-05-10 12:09:07 +0200
committerBjörn Gustavsson <[email protected]>2012-05-10 17:13:03 +0200
commit5c2dad487e6af1a48fa3a1f3d985b6b891788bde (patch)
tree48b44d556ee013786bf21babafd138d253e4de08 /erts/configure.in
parent422b10bbbd1eb27163d72c2586c2bfb0b2d9c9b2 (diff)
downloadotp-5c2dad487e6af1a48fa3a1f3d985b6b891788bde.tar.gz
otp-5c2dad487e6af1a48fa3a1f3d985b6b891788bde.tar.bz2
otp-5c2dad487e6af1a48fa3a1f3d985b6b891788bde.zip
Remove stale code for hybrid heap and incremental GC
The hybrid heap emulator was last working in the non-SMP R11B run-time system. When the constant pools were introduced in R12B, the hybrid heap emulator was not updated to handle them. At this point, the harm from reduced readability of the code is greater than any potential usefulness of keeping the code.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in35
1 files changed, 0 insertions, 35 deletions
diff --git a/erts/configure.in b/erts/configure.in
index cb1b00b8b1..500d1490e9 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -157,14 +157,6 @@ AS_HELP_STRING([--without-termcap],
[],
[with_termcap=yes])
-
-AC_ARG_ENABLE(hybrid-heap,
-AS_HELP_STRING([--enable-hybrid-heap], [enable hybrid heap]),
-[ case "$enableval" in
- no) enable_hybrid_heap=no ;;
- *) enable_hybrid_heap=yes ;;
- esac ], enable_hybrid_heap=unknown)
-
AC_ARG_ENABLE(lock-checking,
AS_HELP_STRING([--enable-lock-checking], [enable lock checking]),
[ case "$enableval" in
@@ -3134,33 +3126,6 @@ fi
AC_SUBST(TSP_APP)
#
-# Check if we should build hybrid emulator
-#
-
-AC_MSG_CHECKING([whether a hybrid heap emulator should be built])
-case $enable_hybrid_heap-$host_os in
- yes-*)
- AC_MSG_RESULT([yes; enabled by user])
- ERTS_BUILD_HYBRID_EMU=yes;;
- no-*)
- AC_MSG_RESULT([no; disabled by user])
- ERTS_BUILD_HYBRID_EMU=no;;
- *-win32|*-vxworks) # vxworks have their own "configure scripts"...
- AC_MSG_RESULT([no; default on this platform])
- ERTS_BUILD_HYBRID_EMU=no;;
- *)
- AC_MSG_RESULT([yes; default on this platform])
- ERTS_BUILD_HYBRID_EMU=yes;;
-esac
-
-
-if test $ERTS_BUILD_HYBRID_EMU = yes; then
- AC_DEFINE(ERTS_HAVE_HYBRID_EMU, 1, [Define if the hybrid emulator is built])
-fi
-
-AC_SUBST(ERTS_BUILD_HYBRID_EMU)
-
-#
# Check if we should enable HiPE.
#