aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorFilipe David Manana <[email protected]>2010-04-22 23:40:26 +0100
committerRaimo Niskanen <[email protected]>2010-05-20 15:48:17 +0200
commit3f53a96a8bd0cd4a18f819b6857e6a764706ede5 (patch)
tree04841cd714a6e23ac664a05ff9219dd8e5da474e /erts/configure.in
parent80b231a0874aa5cd68c3d9f0dc7e13b6736a5dd3 (diff)
downloadotp-3f53a96a8bd0cd4a18f819b6857e6a764706ede5.tar.gz
otp-3f53a96a8bd0cd4a18f819b6857e6a764706ede5.tar.bz2
otp-3f53a96a8bd0cd4a18f819b6857e6a764706ede5.zip
Add file:datasync/1 for syncing file contents only
file:datasync/1 invokes the POSIX system call "int fdatasync(int fd)". This system call is similar to "fsync" but, unlike fsync, it does not update the metadata associated with the file (like the access time for example). It's used by many DBMSs (MySQL and SQLite of example) to increase disk IO performance, as it avoids disk seeks and disk write operations compared to fsync. More details on it at: http://linux.die.net/man/2/fdatasync An example, from the MySQL source: http://bazaar.launchpad.net/~mysql/mysql-server/mysql-5.1-telco-6.1/annotate/head%3A/mysys/my_sync.c#L61 This new function just calls fsync on systems not implementing fdatasync.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index a14b10adbf..f11aba1b15 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1757,6 +1757,12 @@ fi
dnl Need by run_erl.
AC_CHECK_FUNCS([openpty])
+dnl fdatasync syscall (Unix only)
+AC_CHECK_FUNCS([fdatasync])
+
+dnl Find which C libraries are required to use fdatasync
+AC_SEARCH_LIBS(fdatasync, [rt])
+
dnl ----------------------------------------------------------------------
dnl Checks for features/quirks in the system that affects Erlang.
dnl ----------------------------------------------------------------------