aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorMikael Pettersson <[email protected]>2015-03-23 15:20:30 +0100
committerZandra Hird <[email protected]>2015-04-20 11:47:39 +0200
commit87574e845a84c1d6744ac533803ae4fbd2dda8b8 (patch)
treef0ca01e660a05ef478c4973803ef3970281e2c32 /erts/configure.in
parentddfbbcbbd489913120a55b2a054b046c68b40a8a (diff)
downloadotp-87574e845a84c1d6744ac533803ae4fbd2dda8b8.tar.gz
otp-87574e845a84c1d6744ac533803ae4fbd2dda8b8.tar.bz2
otp-87574e845a84c1d6744ac533803ae4fbd2dda8b8.zip
erts/configure.in: handle more 'linux' spellings
The configuration code which canonicalizes the operating system name into OPSYS requires Linux to be spelled 'linux' or 'Linux'. This is a problem in some build environments, e.g. RPM, which supply --build and --host using the longer 'linux-gnu' spelling. The effect is that OPSYS becomes 'noopsys' and some checks in erts/configure.in do not work as expected, e.g. the auto-enabling of HiPE may not happen. Fixed by matching on 'linux*' not just 'linux'. On ARM there are even longer variants such as 'linux-gnueabi' and 'linux-gnueabihf': these are also correctly mapped to 'linux' now.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 481dfe405e..873e1e30fe 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -631,7 +631,7 @@ fi
case $chk_opsys_ in
win32) OPSYS=win32;;
solaris2.*|SunOS5.*) OPSYS=sol2;;
- linux|Linux) OPSYS=linux;;
+ linux*|Linux) OPSYS=linux;;
darwin|Darwin) OPSYS=darwin;;
freebsd|FreeBSD) OPSYS=freebsd;;
*) OPSYS=noopsys