aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorSverker Eriksson <[email protected]>2016-02-25 18:30:27 +0100
committerSverker Eriksson <[email protected]>2016-02-25 18:30:27 +0100
commit3121171f56c2d4a273b89a9d1d47d9f50e027770 (patch)
tree7581fc2851b75171a7f4c482324e5299639fed12 /erts/configure.in
parent5058b37d878f8cdf43c351ab4f05985196630c2b (diff)
downloadotp-3121171f56c2d4a273b89a9d1d47d9f50e027770.tar.gz
otp-3121171f56c2d4a273b89a9d1d47d9f50e027770.tar.bz2
otp-3121171f56c2d4a273b89a9d1d47d9f50e027770.zip
otp: Add gcc option -Werror=implicit
to get errors for missing function and variable declarations.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index ba735fe921..8d178107a0 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -584,6 +584,7 @@ fi
if test "x$GCC" = xyes; then
# Treat certain GCC warnings as errors
LM_TRY_ENABLE_CFLAG([-Werror=return-type], [WERRORFLAGS])
+ LM_TRY_ENABLE_CFLAG([-Werror=implicit], [WERRORFLAGS])
# until the emulator can handle this, I suggest we turn it off!
#WFLAGS="-Wall -Wshadow -Wcast-qual -Wmissing-declarations"