aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorMichael Santos <[email protected]>2010-07-21 14:50:58 -0400
committerRaimo Niskanen <[email protected]>2010-09-03 16:52:28 +0200
commit8393c5d5b682f8acbdc0ecf5b0e6f87589a314cb (patch)
tree969d5157e09771f4743cfa52987abb62a2fc9a28 /erts/configure.in
parentd61d41e235bc464a15925e6fd1b7e9138477d3b3 (diff)
downloadotp-8393c5d5b682f8acbdc0ecf5b0e6f87589a314cb.tar.gz
otp-8393c5d5b682f8acbdc0ecf5b0e6f87589a314cb.tar.bz2
otp-8393c5d5b682f8acbdc0ecf5b0e6f87589a314cb.zip
inet: support retrieving MAC address on BSD
On systems supporting getaddrinfo(), support looking up the MAC address from inet:ifget/2. The results have the same quirks as with Linux: if the MAC address is longer than 6 bytes (e.g., fw0 under Mac OS X), the address is truncated; if the interface does not have a MAC address (e.g., lo0), an address consisting of 0's is returned.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 63bf548c89..74cb9533f3 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1764,6 +1764,9 @@ AC_CHECK_FUNCS([fdatasync])
dnl Find which C libraries are required to use fdatasync
AC_SEARCH_LIBS(fdatasync, [rt])
+AC_CHECK_HEADERS(net/if_dl.h ifaddrs.h)
+AC_CHECK_FUNCS([getifaddrs])
+
dnl ----------------------------------------------------------------------
dnl Checks for features/quirks in the system that affects Erlang.
dnl ----------------------------------------------------------------------