aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2010-02-08 14:04:16 +0000
committerErlang/OTP <[email protected]>2010-02-08 15:54:01 +0100
commita4e2377c72f2e6f018792dff10ed967f08cfac5f (patch)
tree2d5e2debd474214220c59a7596934ee26ed64e07 /erts/configure.in
parent2db75179169db7ae0126f4d12d6f8a16fded84eb (diff)
downloadotp-a4e2377c72f2e6f018792dff10ed967f08cfac5f.tar.gz
otp-a4e2377c72f2e6f018792dff10ed967f08cfac5f.tar.bz2
otp-a4e2377c72f2e6f018792dff10ed967f08cfac5f.zip
OTP-8412 Fixed numerous compiler warnings generated by gcc 4.4.1 and
tile-cc 2.0.1.78377 when compiling the runtime system.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 3d57c2307e..0115ae2ff5 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -492,7 +492,16 @@ fi
if test "x$GCC" = xyes; then
# until the emulator can handle this, I suggest we turn it off!
#WFLAGS="-Wall -Wshadow -Wcast-qual -Wmissing-declarations"
- WFLAGS="-Wall -Wstrict-prototypes -Wmissing-prototypes"
+ WFLAGS="-Wall -Wstrict-prototypes"
+
+ case "$host_cpu" in
+ tile*)
+ # tile-gcc is a bit stricter with -Wmissing-prototypes than other gccs,
+ # and too strict for our taste.
+ ;;
+ *)
+ WFLAGS="$WFLAGS -Wmissing-prototypes";;
+ esac
saved_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -Wdeclaration-after-statement"