aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorAnthony Ramine <[email protected]>2013-02-09 13:46:52 +0100
committerAnthony Ramine <[email protected]>2013-04-27 14:59:31 +0200
commitb9345b4f9c44ea7dea994cb3b06d639f9bf66a8d (patch)
tree690b28de76164a356ee544d6f2edab71826f9a60 /erts/configure.in
parent01824e46557807f21df4db973e7f814e73bd36f8 (diff)
downloadotp-b9345b4f9c44ea7dea994cb3b06d639f9bf66a8d.tar.gz
otp-b9345b4f9c44ea7dea994cb3b06d639f9bf66a8d.tar.bz2
otp-b9345b4f9c44ea7dea994cb3b06d639f9bf66a8d.zip
Support wide characters in the shell through wcwidth()
There is one remaining bug where ttsl_drv's state ends up inconsistent with the terminal own state; when a wide character is entered on the last column of the terminal. Reported-by: Loïc Hoguin
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 2ee907b6e4..f96af03eba 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1342,6 +1342,17 @@ if test "x$TERMCAP_LIB" != "x"; then
AC_DEFINE(HAVE_TERMCAP, 1, [Define if termcap functions exists])
fi
+if test "X$host" != "Xwin32"; then
+ AC_MSG_CHECKING(for wcwidth)
+ AC_TRY_LINK([#include <wchar.h>], [wcwidth(0);],
+ have_wcwidth=yes, have_wcwidth=no)
+ if test $have_wcwidth = yes; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_WCWIDTH, [1],
+ [Define to 1 if you have a `wcwidth' function.])
+ fi
+fi
+
dnl -------------
dnl zlib
dnl -------------