aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorBjörn Gustavsson <[email protected]>2011-01-17 15:29:48 +0100
committerBjörn Gustavsson <[email protected]>2011-01-17 15:29:48 +0100
commitfaef041a446314bb228e0e8c88a09241df2798f1 (patch)
tree728f73a167f50a46b54617a6cc054807064236e9 /erts/configure.in
parent7bc25db7f9a70190a661b2a97734900893d33169 (diff)
parent3f1fce3929cc0cc68d7e5b1ce543bd3f20a31e2b (diff)
downloadotp-faef041a446314bb228e0e8c88a09241df2798f1.tar.gz
otp-faef041a446314bb228e0e8c88a09241df2798f1.tar.bz2
otp-faef041a446314bb228e0e8c88a09241df2798f1.zip
Merge branch 'bjorn/beam-loader/OTP-9030' into dev
* bjorn/beam-loader/OTP-9030: (43 commits) c: Reduce memory footprint erl_posix_msg: Reduce memory footprint Introduce a few more variations of the move instructions Combine a move + jump sequence into the move_jump instruction Optimize and clean-up the exact equality/non-equality instructions Optimize addition of a small integer to a variable Introduce a special instruction for select_val with two values Introduce a few more specialized put_list instructions Eliminate the "put_list c n Dst" instructions Eliminate the specific move_sd instruction Eliminate use of GetArg1() in the badmatch and case_end instructions Eliminate use of GetArg2() in the i_element instruction Eliminate use of GetArg1() in the fast_element instruction Eliminate use of GetArg1() in the jump_on_val* instructions Eliminate use of GetArg1() in the select_val instruction beam_emu: Eliminate sloppy use of tmp_arg1 and tmp_arg2 beam_emu: Don't inline helper functions into process_main() beam_emu: Clean up calling of the error_handler module Simplify a select_val instruction that selects only one value Optimize creation of tuples ...
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 6e983a07b0..627f734409 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -580,6 +580,11 @@ AC_SUBST(WFLAGS)
AC_SUBST(CFLAG_RUNTIME_LIBRARY_PATH)
AC_CHECK_SIZEOF(void *) # Needed for ARCH and smp checks below
+if test "x$ac_cv_sizeof_void_p" = x8; then
+ AC_SUBST(EXTERNAL_WORD_SIZE, 64)
+else
+ AC_SUBST(EXTERNAL_WORD_SIZE, 32)
+fi
dnl
dnl Figure out operating system and cpu architecture