aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2010-08-26 14:55:34 +0200
committerRickard Green <[email protected]>2010-08-27 14:29:24 +0200
commitaf6295211178e1237df6b9b05b5cfe275238e8dc (patch)
treeda5caf385a3ca913b8952309965ddd1dd25ef574 /erts/configure.in
parent1b4a6172d8d2df4362d6d084daef02804e10ebb6 (diff)
downloadotp-af6295211178e1237df6b9b05b5cfe275238e8dc.tar.gz
otp-af6295211178e1237df6b9b05b5cfe275238e8dc.tar.bz2
otp-af6295211178e1237df6b9b05b5cfe275238e8dc.zip
Fix SSL build failure when building in minimal source tree
Building in a source tree without prebuilt platform independent build results failed on the SSL examples when cross building. This has been solved by not building the SSL examples during a cross build.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 5d02fd1ee4..9cc0307e37 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -90,6 +90,13 @@ else
host_os=$host
fi
+if test "$cross_compiling" = "yes"; then
+ CROSS_COMPILING=yes
+else
+ CROSS_COMPILING=no
+fi
+AC_SUBST(CROSS_COMPILING)
+
ERL_XCOMP_SYSROOT_INIT
AC_ISC_POSIX
@@ -3605,7 +3612,7 @@ dnl Should one use EXEEXT or ac_exeext?
if test -f "$erl_xcomp_sysroot$SSL_BINDIR/openssl$EXEEXT"; then
if test "$cross_compiling" = "yes"; then
dnl Cannot test it; hope it is working...
- OPENSSL_CMD="$SSL_BINDIR/openssl"
+ OPENSSL_CMD="$erl_xcomp_sysroot$SSL_BINDIR/openssl"
else
if "$SSL_BINDIR/openssl" version > /dev/null 2>&1; then
OPENSSL_CMD="$SSL_BINDIR/openssl"