aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorMikael Pettersson <[email protected]>2015-02-08 21:19:35 +0100
committerZandra Hird <[email protected]>2015-02-19 09:46:32 +0100
commitcfa9229ba1eb8851caecfc92ca1bc9813fb1d567 (patch)
tree2009b00c72b79734f5c433ab6afb5eae544607f3 /erts/configure.in
parent9d8327c62a981bcc436e5f9fc5466f5539dce3dc (diff)
downloadotp-cfa9229ba1eb8851caecfc92ca1bc9813fb1d567.tar.gz
otp-cfa9229ba1eb8851caecfc92ca1bc9813fb1d567.tar.bz2
otp-cfa9229ba1eb8851caecfc92ca1bc9813fb1d567.zip
remove perfctr support
Perfctr is a Linux kernel extension that allows programmatic access to the performance monitoring counters found in most current CPUs. However, development of perfctr ceased after 2010, and it cannot be used with Linux kernels newer than 2.6.32. Therefore the perfctr support code in the Erlang VM is effectively dead code, so this patch removes it.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in31
1 files changed, 0 insertions, 31 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 7cb6b50708..f248cbe34d 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -264,24 +264,6 @@ AS_HELP_STRING([--enable-m32-build],
esac
],enable_m32_build=no)
-AC_SUBST(PERFCTR_PATH)
-AC_ARG_WITH(perfctr,
-AS_HELP_STRING([--with-perfctr=PATH],
- [specify location of perfctr include and lib])
-AS_HELP_STRING([--without-perfctr], [don't use perfctr (default)]))
-
-if test "x$with_perfctr" = "xno" -o "x$with_perfctr" = "x" ; then
- PERFCTR_PATH=
-else
- if test ! -f "$with_perfctr/usr.lib/libperfctr.a" ; then
- AC_MSG_ERROR(Invalid path to option --with-perfctr=PATH)
- fi
- PERFCTR_PATH="$with_perfctr"
- AC_DEFINE(USE_PERFCTR,[1],
- [Define to enable hrvtime() on Linux systems with perfctr extension])
-fi
-
-
AC_ARG_WITH(dynamic-trace,
AS_HELP_STRING([--with-dynamic-trace={dtrace|systemtap}],
[specify use of dynamic trace framework, dtrace or systemtap])
@@ -3503,19 +3485,6 @@ fi
AC_SUBST(NATIVE_LIBS_ENABLED)
#
-# Check if HiPE should use a standard installation of perfctr.
-#
-AC_SUBST(USE_PERFCTR)
-if test "x$HIPE_ENABLED" = "xyes" ; then
- if test "x$with_perfctr" = "x" ; then
- AC_CHECK_LIB(perfctr, vperfctr_info, [USE_PERFCTR=1
- AC_DEFINE(USE_PERFCTR,[1],[Define to enable hrvtime() on Linux systems with perfctr extension])])
- elif test "x$with_perfctr" != "xno" ; then
- USE_PERFCTR=1
- fi
-fi
-
-#
# Check for working poll().
#
AC_MSG_CHECKING([for working poll()])