aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorLukas Larsson <[email protected]>2018-10-18 12:07:05 +0200
committerLukas Larsson <[email protected]>2018-12-03 13:36:50 +0100
commit3e6890af1d8d5ec9e7ae51bf3ed439906d43905b (patch)
treed6f1b03243744a38e1298efdd00853793b0430f1 /erts/configure.in
parenta2d9a51091578da0ef41fbd91b281091d20aca2b (diff)
downloadotp-3e6890af1d8d5ec9e7ae51bf3ed439906d43905b.tar.gz
otp-3e6890af1d8d5ec9e7ae51bf3ed439906d43905b.tar.bz2
otp-3e6890af1d8d5ec9e7ae51bf3ed439906d43905b.zip
erts: Allow code_model_small to be set in xcomp setting
OTP-15473
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/erts/configure.in b/erts/configure.in
index bcdc6cd083..1b6d187bcb 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -3156,7 +3156,11 @@ AC_TRY_RUN([
],
erl_code_model_small=yes,
erl_code_model_small=no,
-erl_code_model_small=no)
+[case X$erl_xcomp_code_model_small in
+ X) erl_code_model_small=no;;
+ Xyes|Xno) erl_code_model_small=$erl_xcomp_code_model_small;;
+ *) AC_MSG_ERROR([Bad erl_xcomp_code_model_small value: $erl_xcomp_code_model_small]);;
+ esac])
AC_MSG_RESULT([$erl_code_model_small])
LDFLAGS="$saved_LDFLAGS"
case $erl_code_model_small in