aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorBjörn Gustavsson <[email protected]>2017-05-12 13:54:32 +0200
committerBjörn Gustavsson <[email protected]>2017-05-16 10:19:37 +0200
commit4b216f70be3403bb7c102e7ac1a91b1ee4805c33 (patch)
tree9343836986b792c97e98cb281fce6cf03c6f39b4 /erts/configure.in
parent773c4d4f0416f25e3c0c6939f8d0871dc4486bab (diff)
downloadotp-4b216f70be3403bb7c102e7ac1a91b1ee4805c33.tar.gz
otp-4b216f70be3403bb7c102e7ac1a91b1ee4805c33.tar.bz2
otp-4b216f70be3403bb7c102e7ac1a91b1ee4805c33.zip
Let --enable-lock-counter build an additional emulator
"./configure --enable-lock-counter" would modify the behavior of the default emulator (usually SMP). To make lock counting more accessible, change --enable-lock-counter to build an additional emulator in the same way as: (cd erts/emulator && make lcnt) (The next commit will make it easier to start the built lock-counter emulator.)
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/erts/configure.in b/erts/configure.in
index c82ebaa74c..830e3d7776 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1002,6 +1002,7 @@ else
fi
FLAVORS=
+TYPES=opt
ERTS_BUILD_SMP_EMU=$enable_smp_support
AC_MSG_CHECKING(whether an emulator with smp support should be built)
case $ERTS_BUILD_SMP_EMU in
@@ -1210,6 +1211,7 @@ esac
AC_SUBST(ERTS_BUILD_PLAIN_EMU)
AC_SUBST(FLAVORS)
+AC_SUBST(TYPES)
case "$ERTS_BUILD_PLAIN_EMU-$ERTS_BUILD_SMP_EMU" in
no-no)
@@ -1365,7 +1367,7 @@ else
AC_MSG_CHECKING(whether lock counters should be enabled)
AC_MSG_RESULT($enable_lock_count)
if test "x$enable_lock_count" != "xno"; then
- EMU_THR_DEFS="$EMU_THR_DEFS -DERTS_ENABLE_LOCK_COUNT"
+ TYPES="$TYPES lcnt"
fi
case $host_os in