aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorBjörn Gustavsson <[email protected]>2017-10-03 10:11:18 +0200
committerBjörn Gustavsson <[email protected]>2017-10-05 12:37:56 +0200
commite1c9772ffdacae4007209ac5a82758b8e0d3cec4 (patch)
tree951cc6b18823b447f41660d97bc36a44c8ce8b41 /erts/configure.in
parent15099d5752d99587b24e00335713af9d82f16c34 (diff)
downloadotp-e1c9772ffdacae4007209ac5a82758b8e0d3cec4.tar.gz
otp-e1c9772ffdacae4007209ac5a82758b8e0d3cec4.tar.bz2
otp-e1c9772ffdacae4007209ac5a82758b8e0d3cec4.zip
Move LD flags for hipe from Makefile.in to configure.in
We want the flags to be available for other tests in configure.in.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 9dec562f33..85e167b93b 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -2766,6 +2766,20 @@ if test X${enable_hipe} = Xyes && test X$ARCH = Xamd64; then
LDFLAGS=$saved_LDFLAGS])])])
fi
+if test X${enable_hipe} = Xyes; then
+ case $OPSYS in
+ linux)
+ ppcBEAMLDFLAGS="-Wl,-m,elf32ppc"
+ ppc64BEAMLDFLAGS="-Wl,-m,elf64ppc,-T,hipe/elf64ppc.x"
+ ;;
+ darwin)
+ amd64BEAMLDFLAGS="-pagezero_size 0x10000000"
+ ;;
+ esac
+ archVarName="${ARCH}BEAMLDFLAGS"
+ eval HIPEBEAMLDFLAGS=\$$archVarName
+fi
+AC_SUBST(HIPEBEAMLDFLAGS)
if test X${enable_fp_exceptions} = Xauto ; then
case $host_os in