aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorBjörn Gustavsson <[email protected]>2016-11-24 10:11:13 +0100
committerBjörn Gustavsson <[email protected]>2016-12-02 13:19:58 +0100
commite30294f44d02200c20a80f1a3a2bb075afc3747d (patch)
tree8e021ec4ef75a34efc165af79b1d483429451999 /erts/configure.in
parent25aa0128340d819e85e641f0ef8b9e0fd5fdda0b (diff)
downloadotp-e30294f44d02200c20a80f1a3a2bb075afc3747d.tar.gz
otp-e30294f44d02200c20a80f1a3a2bb075afc3747d.tar.bz2
otp-e30294f44d02200c20a80f1a3a2bb075afc3747d.zip
configure.in: Fix configure test for usable OpenSSL
In OpenSSL 1.1.0, HMAC_CTX no longer has a complete definition, and can no longer be allocated as a stack variable. Therefore, the code in the configure test for usable OpenSSL library will not compile. Call the HMAC() function instead since it exists in all versions of of OpenSSL that we support. Note that the code will only be compiled and linked, not run, so the argument values don't matter as long as they have the correct type.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/erts/configure.in b/erts/configure.in
index fd7dc783f3..2018e19b76 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -4285,8 +4285,7 @@ yes
#include <stdio.h>
#include <openssl/hmac.h>],
[
- HMAC_CTX hc;
- HMAC_CTX_init(&hc);
+ HMAC(0, 0, 0, 0, 0, 0, 0);
],
[ssl_linkable=yes],
[ssl_linkable=no])
@@ -4341,8 +4340,7 @@ dnl so it is - be adoptable
#include <stdio.h>
#include <openssl/hmac.h>],
[
- HMAC_CTX hc;
- HMAC_CTX_init(&hc);
+ HMAC(0, 0, 0, 0, 0, 0, 0);
],
[ssl_dyn_linkable=yes],
[ssl_dyn_linkable=no])
@@ -4605,8 +4603,7 @@ yes) # Use standard lib locations for ssl runtime library path
#include <openssl/hmac.h>
],
[
- HMAC_CTX hc;
- HMAC_CTX_init(&hc);
+ HMAC(0, 0, 0, 0, 0, 0, 0);
],
[rpath_success=yes],
[rpath_success=no])