aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2010-08-27 13:28:43 +0200
committerRickard Green <[email protected]>2010-08-27 14:51:22 +0200
commit22fe8c9f870f5b20f1cb9e740ff20a15331472f9 (patch)
treef7d1d0d6073ba2f7086ea6a76ed5d41b5b6fe883 /erts/configure.in
parentaf6295211178e1237df6b9b05b5cfe275238e8dc (diff)
downloadotp-22fe8c9f870f5b20f1cb9e740ff20a15331472f9.tar.gz
otp-22fe8c9f870f5b20f1cb9e740ff20a15331472f9.tar.bz2
otp-22fe8c9f870f5b20f1cb9e740ff20a15331472f9.zip
Fix SSL build failure when building in minimal source tree
Building in a source tree without prebuilt platform independent build results failed on the SSL examples when building on Windows.
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 9cc0307e37..d5dccdbb83 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -3612,10 +3612,10 @@ dnl Should one use EXEEXT or ac_exeext?
if test -f "$erl_xcomp_sysroot$SSL_BINDIR/openssl$EXEEXT"; then
if test "$cross_compiling" = "yes"; then
dnl Cannot test it; hope it is working...
- OPENSSL_CMD="$erl_xcomp_sysroot$SSL_BINDIR/openssl"
+ OPENSSL_CMD="$erl_xcomp_sysroot$SSL_BINDIR/openssl$EXEEXT"
else
- if "$SSL_BINDIR/openssl" version > /dev/null 2>&1; then
- OPENSSL_CMD="$SSL_BINDIR/openssl"
+ if "$SSL_BINDIR/openssl$EXEEXT" version > /dev/null 2>&1; then
+ OPENSSL_CMD="$SSL_BINDIR/openssl$EXEEXT"
else
is_real_ssl=no
fi
@@ -3624,6 +3624,9 @@ dnl Should one use EXEEXT or ac_exeext?
is_real_ssl=no
fi
if test "x$is_real_ssl" = "xyes" ; then
+ if test "$MIXED_CYGWIN" = "yes"; then
+ OPENSSL_CMD=`cygpath -s -m "$OPENSSL_CMD"` 2> /dev/null
+ fi
SSL_INCLUDE="-I$dir/include"
old_CPPFLAGS=$CPPFLAGS
CPPFLAGS=$SSL_INCLUDE