aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2010-03-31 11:31:07 +0000
committerErlang/OTP <[email protected]>2010-03-31 11:31:07 +0000
commit88f67c0c3869806d2ec4cec625c47a78fd770156 (patch)
treea20a53f7bf502ea3f304124ac3e37e8e2f7ed119 /erts/configure.in
parentc5d3624d7c9b31ca127792cf15eefc66c1972269 (diff)
downloadotp-88f67c0c3869806d2ec4cec625c47a78fd770156.tar.gz
otp-88f67c0c3869806d2ec4cec625c47a78fd770156.tar.bz2
otp-88f67c0c3869806d2ec4cec625c47a78fd770156.zip
OTP-8484 Fix minor cross compilation issues
The use of mmap() was unnecessarily disabled when cross compiling. The configure arguments --with-ssl, and --with-odbc refused to accept libraries outside of $erl_xcomp_sysroot when cross compiling for no good reason. The configure argument --with-odbc didn't handle the value yes correct. The configure arguments --with-odbc, and --without-odbc have also been added to the configure help. (Thanks to Steve Vinoski for reporting these issues)
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in10
1 files changed, 1 insertions, 9 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 6823133936..6278af3a2e 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1693,7 +1693,7 @@ AC_CHECK_FUNCS([getnameinfo getipnodebyname getipnodebyaddr gethostbyname2])
AC_CHECK_FUNCS([ieee_handler fpsetmask finite isnan isinf res_gethostbyname dlopen \
pread pwrite writev memmove strerror strerror_r strncasecmp \
- gethrtime localtime_r gmtime_r mremap memcpy mallopt \
+ gethrtime localtime_r gmtime_r mmap mremap memcpy mallopt \
sbrk _sbrk __sbrk brk _brk __brk \
flockfile fstat strlcpy strlcat setsid posix2time setlocale nl_langinfo poll])
if test "X$host" = "Xwin32"; then
@@ -1725,7 +1725,6 @@ if test $disable_vfork = true; then
fi
AC_FUNC_VPRINTF
-AC_FUNC_MMAP
dnl The AC_DEFINEs are necessary for autoheader to work. :-(
dnl for gzio
@@ -3729,13 +3728,6 @@ dnl so it is - be adoptable
fi
;;
*)
- if test "$cross_compiling" = "yes"; then
- case "$with_ssl" in
- "$erl_xcomp_sysroot"*) ;;
- *) AC_MSG_ERROR([Invalid path to option --with-ssl=PATH (not a subdirectory to cross system root)]);;
- esac
- fi
-
# Option given with PATH to package
if test ! -d "$with_ssl" ; then
AC_MSG_ERROR(Invalid path to option --with-ssl=PATH)