aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorMicael Karlberg <[email protected]>2019-03-07 17:27:44 +0100
committerMicael Karlberg <[email protected]>2019-04-30 10:58:16 +0200
commit9e34d5b91fda4c1021090fa00a8921cc2c8d2cb8 (patch)
tree8580ab0743b2dee79169b6b30af2d6b225ef7704 /erts/configure.in
parent759ec896d7f254db2996cbb503c1ef883e6714b0 (diff)
downloadotp-9e34d5b91fda4c1021090fa00a8921cc2c8d2cb8.tar.gz
otp-9e34d5b91fda4c1021090fa00a8921cc2c8d2cb8.tar.bz2
otp-9e34d5b91fda4c1021090fa00a8921cc2c8d2cb8.zip
[socket] Preliminary - make socket configurable
Preliminary work to make socket configurable (enable and disable). OTP-15658
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 5f969a0a8b..f17572142d 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1329,6 +1329,28 @@ LIBS=$zlib_save_LIBS
fi
AC_SUBST(Z_LIB)
+
+dnl -------------
+dnl esock
+dnl -------------
+
+AC_ARG_ENABLE(esock,
+AS_HELP_STRING([--enable-esock], [enable builtin experimental socket (as a nif) support (default)])
+AS_HELP_STRING([--disable-esock], [disable builtin experimental socket (as a nif) support]))
+
+dnl Default value
+USE_ESOCK=yes
+
+if test "x$enable_esock" = "xyes"; then
+ USE_ESOCK=yes
+else
+ if test "x$enable_esock" = "xno"; then
+ USE_ESOCK=no
+ fi
+fi
+AC_SUBST(USE_ESOCK)
+
+
dnl
dnl This test kindly borrowed from Tcl
dnl