aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorLukas Larsson <[email protected]>2016-08-12 11:26:48 +0200
committerLukas Larsson <[email protected]>2016-08-12 11:26:48 +0200
commitdaa0f831aee9dedf8cdf29fd5f97f98f55e072e3 (patch)
tree6365e6511bf76044129a7947887200e72e828cbc /erts/configure.in
parent634998007ebd494cc64db244b748ed52bdff6a0a (diff)
parent0e00f80fb74f8f449eacf237e84a698a5555e7bd (diff)
downloadotp-daa0f831aee9dedf8cdf29fd5f97f98f55e072e3.tar.gz
otp-daa0f831aee9dedf8cdf29fd5f97f98f55e072e3.tar.bz2
otp-daa0f831aee9dedf8cdf29fd5f97f98f55e072e3.zip
Merge branch 'binarin/even-more-absolute-paths/PR-1103/OTP-13800' into maint
* binarin/even-more-absolute-paths/PR-1103/OTP-13800: Use perl discovered by configure Don't make assumptions about build tools paths
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in19
1 files changed, 15 insertions, 4 deletions
diff --git a/erts/configure.in b/erts/configure.in
index c5b08547cb..b1830979aa 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -738,6 +738,11 @@ if test "$ac_cv_path_MKDIR" = false; then
AC_MSG_ERROR([No 'mkdir' command found])
fi
+AC_PATH_PROG(CP, cp, false, $_search_path)
+if test "$ac_cv_path_CP" = false; then
+ AC_MSG_ERROR([No 'cp' command found])
+fi
+
_search_path=
@@ -4817,8 +4822,7 @@ dnl Output the result.
dnl ----------------------------------------------------------------------
dnl Note that the output files are relative to $srcdir
-
-AC_OUTPUT(
+AC_CONFIG_FILES([
emulator/$host/Makefile:emulator/Makefile.in
epmd/src/$host/Makefile:epmd/src/Makefile.in
etc/common/$host/Makefile:etc/common/Makefile.in
@@ -4828,15 +4832,22 @@ AC_OUTPUT(
Makefile:Makefile.in
../make/$host/otp.mk:../make/otp.mk.in
../make/$host/otp_ded.mk:../make/otp_ded.mk.in
+])
+
+AC_CONFIG_FILES([../make/make_emakefile:../make/make_emakefile.in],
+ [chmod +x ../make/make_emakefile])
+
dnl
dnl The ones below should be moved to their respective lib
dnl
+dnl ../lib/ssl/c_src/$host/Makefile:../lib/ssl/c_src/Makefile.in
+AC_CONFIG_FILES([
../lib/ic/c_src/$host/Makefile:../lib/ic/c_src/Makefile.in
../lib/os_mon/c_src/$host/Makefile:../lib/os_mon/c_src/Makefile.in
-dnl ../lib/ssl/c_src/$host/Makefile:../lib/ssl/c_src/Makefile.in
../lib/crypto/c_src/$host/Makefile:../lib/crypto/c_src/Makefile.in
../lib/orber/c_src/$host/Makefile:../lib/orber/c_src/Makefile.in
../lib/runtime_tools/c_src/$host/Makefile:../lib/runtime_tools/c_src/Makefile.in
../lib/tools/c_src/$host/Makefile:../lib/tools/c_src/Makefile.in
- )
+ ])
+AC_OUTPUT