aboutsummaryrefslogtreecommitdiffstats
path: root/lib/erl_interface/configure.in
diff options
context:
space:
mode:
authorBjörn-Egil Dahlberg <[email protected]>2013-01-14 15:25:56 +0100
committerBjörn-Egil Dahlberg <[email protected]>2013-01-14 15:25:56 +0100
commitfdd0b38e2c85d897a240e5f8f79e268c6540dbfd (patch)
tree617d9322887f396e186f0c6e6a651a4f46e3d119 /lib/erl_interface/configure.in
parent9a19ba3aba7b2a3c7b58cfd02b7e442138ea7685 (diff)
parent37fb3503c4b1467d2b28f407b9c27c1de147869e (diff)
downloadotp-fdd0b38e2c85d897a240e5f8f79e268c6540dbfd.tar.gz
otp-fdd0b38e2c85d897a240e5f8f79e268c6540dbfd.tar.bz2
otp-fdd0b38e2c85d897a240e5f8f79e268c6540dbfd.zip
Merge branch 'ta/werror-return-type/OTP-10683'
* ta/werror-return-type/OTP-10683: If GCC is used, treat -Wreturn-type as error
Diffstat (limited to 'lib/erl_interface/configure.in')
-rw-r--r--lib/erl_interface/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/erl_interface/configure.in b/lib/erl_interface/configure.in
index 97f1cff345..d511f2e240 100644
--- a/lib/erl_interface/configure.in
+++ b/lib/erl_interface/configure.in
@@ -273,6 +273,8 @@ esac
AC_SUBST(WFLAGS)
if test "x$GCC" = xyes; then
+ # Treat certain GCC warnings as errors
+ LM_TRY_ENABLE_CFLAG([-Werror=return-type], [WERRORFLAGS])
WFLAGS="-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline"
# check which GCC version
GCC_VERSION=`$CC -v 2>&1 | sed -n 's/gcc version //p'`
@@ -287,8 +289,10 @@ if test "x$GCC" = xyes; then
*)
WFLAGS="$WFLAGS -fno-strict-aliasing";;
esac
+ CFLAGS="$WERRORFLAGS $CFLAGS"
else
WFLAGS=""
+ WERRORFLAGS=""
fi
# ---------------------------------------------------------------------------