aboutsummaryrefslogtreecommitdiffstats
path: root/lib/erl_interface/configure.in
diff options
context:
space:
mode:
authorTuncer Ayaz <[email protected]>2012-10-11 19:13:46 +0200
committerBjörn-Egil Dahlberg <[email protected]>2013-01-11 19:57:35 +0100
commit37fb3503c4b1467d2b28f407b9c27c1de147869e (patch)
treeb85c8f0d8655d23392f2d6f455d0d9dc83976d6c /lib/erl_interface/configure.in
parent8df9bc2fc2336245d26bdcf386fee43904d2b34b (diff)
downloadotp-37fb3503c4b1467d2b28f407b9c27c1de147869e.tar.gz
otp-37fb3503c4b1467d2b28f407b9c27c1de147869e.tar.bz2
otp-37fb3503c4b1467d2b28f407b9c27c1de147869e.zip
If GCC is used, treat -Wreturn-type as error
Diffstat (limited to 'lib/erl_interface/configure.in')
-rw-r--r--lib/erl_interface/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/erl_interface/configure.in b/lib/erl_interface/configure.in
index 97f1cff345..d511f2e240 100644
--- a/lib/erl_interface/configure.in
+++ b/lib/erl_interface/configure.in
@@ -273,6 +273,8 @@ esac
AC_SUBST(WFLAGS)
if test "x$GCC" = xyes; then
+ # Treat certain GCC warnings as errors
+ LM_TRY_ENABLE_CFLAG([-Werror=return-type], [WERRORFLAGS])
WFLAGS="-Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline"
# check which GCC version
GCC_VERSION=`$CC -v 2>&1 | sed -n 's/gcc version //p'`
@@ -287,8 +289,10 @@ if test "x$GCC" = xyes; then
*)
WFLAGS="$WFLAGS -fno-strict-aliasing";;
esac
+ CFLAGS="$WERRORFLAGS $CFLAGS"
else
WFLAGS=""
+ WERRORFLAGS=""
fi
# ---------------------------------------------------------------------------