aboutsummaryrefslogtreecommitdiffstats
path: root/lib/erl_interface/configure.in
diff options
context:
space:
mode:
authorSverker Eriksson <[email protected]>2018-04-20 11:36:21 +0200
committerSverker Eriksson <[email protected]>2018-04-20 11:36:21 +0200
commit21754c8d402855af5081dad0aff465a8f0f7eda7 (patch)
tree7af7d292a13b8131bb273f5b77919ff956f1ae78 /lib/erl_interface/configure.in
parentfd8ce7e0592b4d873773dba405de9cfd4e4ec184 (diff)
parentef0284670c2f108e1ef8980e422b48ec04c3728c (diff)
downloadotp-21754c8d402855af5081dad0aff465a8f0f7eda7.tar.gz
otp-21754c8d402855af5081dad0aff465a8f0f7eda7.tar.bz2
otp-21754c8d402855af5081dad0aff465a8f0f7eda7.zip
Merge branch 'sverker/master/optimize-atom-enc-dec/ERIERL-150'
Diffstat (limited to 'lib/erl_interface/configure.in')
-rw-r--r--lib/erl_interface/configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/lib/erl_interface/configure.in b/lib/erl_interface/configure.in
index 0a8fbf513c..696ebf5ca0 100644
--- a/lib/erl_interface/configure.in
+++ b/lib/erl_interface/configure.in
@@ -106,6 +106,19 @@ if test $ac_cv_sizeof_long = 8; then
CFLAGS="$CFLAGS -DEI_64BIT"
fi
+LM_HARDWARE_ARCH
+
+AC_MSG_CHECKING(for unaligned word access)
+case "$ARCH" in
+ x86|amd64)
+ AC_MSG_RESULT(yes: x86 or amd64)
+ AC_DEFINE(HAVE_UNALIGNED_WORD_ACCESS, 1, [Define if hw supports unaligned word access])
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+esac
+
AC_CHECK_TOOL(AR, ar, false)
if test "$AR" = false; then
AC_MSG_ERROR([No 'ar' command found in PATH])