aboutsummaryrefslogtreecommitdiffstats
path: root/lib/erl_interface/configure.in
diff options
context:
space:
mode:
authorDavid N. Welton <[email protected]>2014-12-15 17:53:09 +0100
committerBjörn-Egil Dahlberg <[email protected]>2015-03-19 11:22:37 +0100
commit372d62d4e1738431d33c1318be1ee4305c74649d (patch)
treeb193b74946f5430acd73ec40b3e3288bfa485793 /lib/erl_interface/configure.in
parent243dc2ff02e3be0af2a2f1aadf7e53f09b4bdbc7 (diff)
downloadotp-372d62d4e1738431d33c1318be1ee4305c74649d.tar.gz
otp-372d62d4e1738431d33c1318be1ee4305c74649d.tar.bz2
otp-372d62d4e1738431d33c1318be1ee4305c74649d.zip
Do not accept Nan and Infinity values
Erlang does not accept these values, so we return an error in the C interface rather than letting them through to the Erlang VM, which rejects the message with a somewhat cryptic "bad external term".
Diffstat (limited to 'lib/erl_interface/configure.in')
-rw-r--r--lib/erl_interface/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/lib/erl_interface/configure.in b/lib/erl_interface/configure.in
index ef78f0f87b..076170c648 100644
--- a/lib/erl_interface/configure.in
+++ b/lib/erl_interface/configure.in
@@ -139,6 +139,18 @@ esac
AC_CHECK_LIB([nsl], [gethostbyname])
AC_CHECK_LIB([socket], [getpeername])
+AC_MSG_CHECKING([for isfinite])
+AC_TRY_LINK([#include <math.h>],
+ [isfinite(0);], have_isfinite=yes, have_isfinite=no),
+
+if test $have_isfinite = yes; then
+ AC_DEFINE(HAVE_ISFINITE,[1],
+ [Define to 1 if you have the `isfinite' function.])
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
# Checks for header files.
AC_HEADER_STDC
AC_HEADER_SYS_WAIT