aboutsummaryrefslogtreecommitdiffstats
path: root/lib/erl_interface/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2019-03-07 15:53:19 +0100
committerRickard Green <[email protected]>2019-03-07 16:01:30 +0100
commita4caaef4df6acbdd7c46962004edc1d47504bbf4 (patch)
tree65b1b44ce3d3be457d9483d0fa0e11c68eaf5740 /lib/erl_interface/configure.in
parentc70a0aaeacd91d525c59f9a376022cb87d18e87a (diff)
downloadotp-a4caaef4df6acbdd7c46962004edc1d47504bbf4.tar.gz
otp-a4caaef4df6acbdd7c46962004edc1d47504bbf4.tar.bz2
otp-a4caaef4df6acbdd7c46962004edc1d47504bbf4.zip
Better erl_interface deprecation warning implementation
Diffstat (limited to 'lib/erl_interface/configure.in')
-rw-r--r--lib/erl_interface/configure.in10
1 files changed, 1 insertions, 9 deletions
diff --git a/lib/erl_interface/configure.in b/lib/erl_interface/configure.in
index 67acb7c180..f0e9b2eb3f 100644
--- a/lib/erl_interface/configure.in
+++ b/lib/erl_interface/configure.in
@@ -61,7 +61,7 @@ fi
TARGET=$host
AC_SUBST(TARGET)
-AC_CONFIG_HEADER([src/$host/config.h:config.h.in include/$host/ei_config.h:include/ei_config.h.in])
+AC_CONFIG_HEADER([src/$host/config.h:config.h.in])
dnl ----------------------------------------------------------------------
dnl Optional features
@@ -184,14 +184,6 @@ AC_TRY_COMPILE([#include <sys/types.h>
AC_DEFINE(HAVE_SOCKLEN_T, [], [Define if you have the `socklen_t' type])],
[AC_MSG_RESULT(no)])
-AC_MSG_CHECKING([for deprecated attribute])
-AC_TRY_COMPILE([],
-[void my_function(void) __attribute__((deprecated));],
-[AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_DEPRECATED_ATTRIBUTE, [1], [Define to 1 if you have the `deprecated' attribute])],
-[AC_MSG_RESULT(no)])
-
-
# Checks for library functions.
AC_FUNC_ALLOCA
dnl AC_FUNC_FORK