aboutsummaryrefslogtreecommitdiffstats
path: root/lib/erl_interface/configure.in
diff options
context:
space:
mode:
authorPer Hedeland <[email protected]>2012-11-14 15:10:21 +0100
committerBjörn-Egil Dahlberg <[email protected]>2012-11-14 15:10:21 +0100
commit3660d23158441075dec8e3c08fb513225ec10210 (patch)
tree80dc4243f6d191fe09eeab123b9d3d2515ed2cf1 /lib/erl_interface/configure.in
parent55c2b0b6d55fe6a011671832b5529cb1c7b636a8 (diff)
downloadotp-3660d23158441075dec8e3c08fb513225ec10210.tar.gz
otp-3660d23158441075dec8e3c08fb513225ec10210.tar.bz2
otp-3660d23158441075dec8e3c08fb513225ec10210.zip
Teach erl_interface configure more pthread support
- Teach lib/erl_interface/configure.in to look for pthreads support in libc (where it can be found on QNX) - A minor tweak such that this configure *fails* if you pass --enable-threads and no pthreads support can be found.
Diffstat (limited to 'lib/erl_interface/configure.in')
-rw-r--r--lib/erl_interface/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/lib/erl_interface/configure.in b/lib/erl_interface/configure.in
index c958f80065..f1c9ebbb6f 100644
--- a/lib/erl_interface/configure.in
+++ b/lib/erl_interface/configure.in
@@ -79,7 +79,7 @@ AC_ARG_ENABLE(threads,
no) threads_disabled=yes ;;
*) threads_disabled=no ;;
esac ],
-[ threads_disabled=no ])
+[ threads_disabled=maybe ])
dnl ----------------------------------------------------------------------
dnl Checks for programs
@@ -237,12 +237,16 @@ AC_SUBST(THR_DEFS)
AC_SUBST(EI_THREADS)
case "$threads_disabled" in
- no)
+ no|maybe)
LM_CHECK_THR_LIB
case "$THR_LIB_NAME" in
"")
EI_THREADS="false"
+ # Fail if --enable-threads given and no threads found
+ if test "x$threads_disabled" = "xno"; then
+ AC_MSG_ERROR(No threads support found)
+ fi
;;
win32_threads)
EI_THREADS="true"