aboutsummaryrefslogtreecommitdiffstats
path: root/lib/erl_interface/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2019-02-23 18:59:06 +0100
committerRickard Green <[email protected]>2019-02-25 11:18:32 +0100
commit00fa7a8def826d2a4c8fb9e2c38208103bf04341 (patch)
tree31b57a4087e0e574f294220dda4384102495f303 /lib/erl_interface/configure.in
parent8172af0a1986fe50c3d7ea26baa80fdb423ae13c (diff)
downloadotp-00fa7a8def826d2a4c8fb9e2c38208103bf04341.tar.gz
otp-00fa7a8def826d2a4c8fb9e2c38208103bf04341.tar.bz2
otp-00fa7a8def826d2a4c8fb9e2c38208103bf04341.zip
Document deprecations and removals
Diffstat (limited to 'lib/erl_interface/configure.in')
-rw-r--r--lib/erl_interface/configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/lib/erl_interface/configure.in b/lib/erl_interface/configure.in
index 14f06f946f..53c2f7069c 100644
--- a/lib/erl_interface/configure.in
+++ b/lib/erl_interface/configure.in
@@ -61,7 +61,7 @@ fi
TARGET=$host
AC_SUBST(TARGET)
-AC_CONFIG_HEADER([src/$host/config.h:config.h.in])
+AC_CONFIG_HEADER([src/$host/config.h:config.h.in include/$host/ei_config.h:include/ei_config.h.in])
dnl ----------------------------------------------------------------------
dnl Optional features
@@ -184,6 +184,14 @@ AC_TRY_COMPILE([#include <sys/types.h>
AC_DEFINE(HAVE_SOCKLEN_T, [], [Define if you have the `socklen_t' type])],
[AC_MSG_RESULT(no)])
+AC_MSG_CHECKING([for deprecated attribute])
+AC_TRY_COMPILE([],
+[void my_function(void) __attribute__((deprecated));],
+[AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_DEPRECATED_ATTRIBUTE, [], [Define to 1 if you have the `deprecated' attribute])],
+[AC_MSG_RESULT(no)])
+
+
# Checks for library functions.
AC_FUNC_ALLOCA
dnl AC_FUNC_FORK
@@ -360,6 +368,7 @@ LDFLAGS="$LDFLAGS $sanitizers"
# XXX
# ---------------------------------------------------------------------------
+
AC_OUTPUT(
src/$host/Makefile:src/Makefile.in
src/$host/eidefs.mk:src/eidefs.mk.in