aboutsummaryrefslogtreecommitdiffstats
path: root/lib/hipe/test/hipe.spec
diff options
context:
space:
mode:
authorKostis Sagonas <[email protected]>2014-01-12 20:10:49 +0100
committerHenrik Nord <[email protected]>2014-02-24 16:57:30 +0100
commit7dae40dd0d595776eec7c0407a7849962650e762 (patch)
treeed38c5c773db2c8d55ea5662ee27cbe71ee65f2f /lib/hipe/test/hipe.spec
parent4ce83eb728748787f8a2da6155112c6da42a0eba (diff)
downloadotp-7dae40dd0d595776eec7c0407a7849962650e762.tar.gz
otp-7dae40dd0d595776eec7c0407a7849962650e762.tar.bz2
otp-7dae40dd0d595776eec7c0407a7849962650e762.zip
Add tests for the HiPE compiler (Part 1: binaries and bitstrings)
Create tests for the HiPE native code compiler. This is the first part of the effort and contains tests that check that the native code produced by the HiPE compiler for binaries and bitstrings is OK and behaves similarly to the code produced by the BEAM compiler.
Diffstat (limited to 'lib/hipe/test/hipe.spec')
-rw-r--r--lib/hipe/test/hipe.spec7
1 files changed, 6 insertions, 1 deletions
diff --git a/lib/hipe/test/hipe.spec b/lib/hipe/test/hipe.spec
index 6b0b226dc3..2894f40354 100644
--- a/lib/hipe/test/hipe.spec
+++ b/lib/hipe/test/hipe.spec
@@ -1 +1,6 @@
-{suites,"../hipe_test",all}.
+%% -*- erlang -*-
+
+{alias, tests, "../hipe_test"}.
+
+{suites, tests, all}.
+