aboutsummaryrefslogtreecommitdiffstats
path: root/lib/megaco/configure.in
diff options
context:
space:
mode:
authorTuncer Ayaz <[email protected]>2012-10-11 19:13:46 +0200
committerBjörn-Egil Dahlberg <[email protected]>2013-01-11 19:57:35 +0100
commit37fb3503c4b1467d2b28f407b9c27c1de147869e (patch)
treeb85c8f0d8655d23392f2d6f455d0d9dc83976d6c /lib/megaco/configure.in
parent8df9bc2fc2336245d26bdcf386fee43904d2b34b (diff)
downloadotp-37fb3503c4b1467d2b28f407b9c27c1de147869e.tar.gz
otp-37fb3503c4b1467d2b28f407b9c27c1de147869e.tar.bz2
otp-37fb3503c4b1467d2b28f407b9c27c1de147869e.zip
If GCC is used, treat -Wreturn-type as error
Diffstat (limited to 'lib/megaco/configure.in')
-rw-r--r--lib/megaco/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/megaco/configure.in b/lib/megaco/configure.in
index 722ccc3fb4..9c3858f562 100644
--- a/lib/megaco/configure.in
+++ b/lib/megaco/configure.in
@@ -273,6 +273,11 @@ if test "$PERL" = no_perl; then
AC_MSG_ERROR([Perl is required to build the flex scanner!])
fi
+if test "x$GCC" = xyes; then
+ # Treat certain GCC warnings as errors
+ LM_TRY_ENABLE_CFLAG([-Werror=return-type], [CFLAGS])
+fi
+
AC_OUTPUT(examples/meas/Makefile:examples/meas/Makefile.in)
AC_OUTPUT(src/flex/$host/Makefile:src/flex/Makefile.in)