aboutsummaryrefslogtreecommitdiffstats
path: root/lib/megaco/configure.in
diff options
context:
space:
mode:
authorBjörn-Egil Dahlberg <[email protected]>2013-01-14 15:25:56 +0100
committerBjörn-Egil Dahlberg <[email protected]>2013-01-14 15:25:56 +0100
commitfdd0b38e2c85d897a240e5f8f79e268c6540dbfd (patch)
tree617d9322887f396e186f0c6e6a651a4f46e3d119 /lib/megaco/configure.in
parent9a19ba3aba7b2a3c7b58cfd02b7e442138ea7685 (diff)
parent37fb3503c4b1467d2b28f407b9c27c1de147869e (diff)
downloadotp-fdd0b38e2c85d897a240e5f8f79e268c6540dbfd.tar.gz
otp-fdd0b38e2c85d897a240e5f8f79e268c6540dbfd.tar.bz2
otp-fdd0b38e2c85d897a240e5f8f79e268c6540dbfd.zip
Merge branch 'ta/werror-return-type/OTP-10683'
* ta/werror-return-type/OTP-10683: If GCC is used, treat -Wreturn-type as error
Diffstat (limited to 'lib/megaco/configure.in')
-rw-r--r--lib/megaco/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/megaco/configure.in b/lib/megaco/configure.in
index 722ccc3fb4..9c3858f562 100644
--- a/lib/megaco/configure.in
+++ b/lib/megaco/configure.in
@@ -273,6 +273,11 @@ if test "$PERL" = no_perl; then
AC_MSG_ERROR([Perl is required to build the flex scanner!])
fi
+if test "x$GCC" = xyes; then
+ # Treat certain GCC warnings as errors
+ LM_TRY_ENABLE_CFLAG([-Werror=return-type], [CFLAGS])
+fi
+
AC_OUTPUT(examples/meas/Makefile:examples/meas/Makefile.in)
AC_OUTPUT(src/flex/$host/Makefile:src/flex/Makefile.in)