aboutsummaryrefslogtreecommitdiffstats
path: root/lib/megaco/configure.in
diff options
context:
space:
mode:
authorBjörn-Egil Dahlberg <[email protected]>2013-01-15 17:32:19 +0100
committerBjörn-Egil Dahlberg <[email protected]>2013-01-15 17:32:19 +0100
commitdc60870eb02edb6b0163a77cc9ca523d692bc385 (patch)
treed3c018b4f259c74c85a2cf9bb33d7ca42002e27a /lib/megaco/configure.in
parentfa6771380931c7ded0ad4d36e6cd2554bb932dfc (diff)
downloadotp-dc60870eb02edb6b0163a77cc9ca523d692bc385.tar.gz
otp-dc60870eb02edb6b0163a77cc9ca523d692bc385.tar.bz2
otp-dc60870eb02edb6b0163a77cc9ca523d692bc385.zip
Fix LM_TRY_ENABLE_CFLAG to use correct environment
LM_TRY_ENABLE_CFLAG takes which environment variable should be updated but only CFLAGS was updated. Though CFLAGS is the normally the intended variable, others may be used. For instance CXXFLAGS.
Diffstat (limited to 'lib/megaco/configure.in')
-rw-r--r--lib/megaco/configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/lib/megaco/configure.in b/lib/megaco/configure.in
index 9c3858f562..643267a154 100644
--- a/lib/megaco/configure.in
+++ b/lib/megaco/configure.in
@@ -162,6 +162,11 @@ else
fi
AC_SUBST(OTP_EXTRA_FLAGS)
+if test "x$GCC" = xyes; then
+ # Treat certain GCC warnings as errors
+ LM_TRY_ENABLE_CFLAG([-Werror=return-type], [CFLAGS])
+fi
+
dnl
dnl If ${ERL_TOP}/make/otp_ded.mk.in exists and contains DED_MK_VSN > 0,
dnl every thing releted to compiling Dynamic Erlang Drivers can be found
@@ -273,11 +278,6 @@ if test "$PERL" = no_perl; then
AC_MSG_ERROR([Perl is required to build the flex scanner!])
fi
-if test "x$GCC" = xyes; then
- # Treat certain GCC warnings as errors
- LM_TRY_ENABLE_CFLAG([-Werror=return-type], [CFLAGS])
-fi
-
AC_OUTPUT(examples/meas/Makefile:examples/meas/Makefile.in)
AC_OUTPUT(src/flex/$host/Makefile:src/flex/Makefile.in)